View Issue Details

IDProjectCategoryView StatusLast Update
0000008jFermiGeneralpublic2020-09-30 14:45
Reporterguttmann Assigned Toguttmann  
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Summary0000008: pump control device disappears from i2c bus
Descriptionafter jfermi startup sometimes the pump control device disappears from i2c bus
problem could be becase each stack device hava its own i2c pullup resistor!
TagsNo tags attached.

Activities

guttmann

2020-04-23 18:08

administrator   ~0000001

in the problematic bioreactor the upspico and a raspberry module was replace and that solved the problem
currently the pump module seems to be ok, the pump module in question was tried in an other bioreactor an worked fine there
however i could not find the real cause of the problem, the synthomps was: after the second startup of the fermentor the pump module simply did not start, not event a very simple led (heartbeat) blinking application.
if the problem comes up again, it worths to try to add brown-out reset feature and watchdog to the pump modules

Issue History

Date Modified Username Field Change
2020-04-11 07:55 guttmann New Issue
2020-04-11 07:55 guttmann Status new => assigned
2020-04-11 07:55 guttmann Assigned To => guttmann
2020-04-11 08:00 guttmann Category Base Hardware => General
2020-04-11 08:06 guttmann Reproducibility have not tried => sometimes
2020-04-11 08:06 guttmann Target Version => 1.1
2020-04-23 18:00 guttmann Status assigned => resolved
2020-04-23 18:00 guttmann Fixed in Version => 1.1
2020-04-23 18:08 guttmann Note Added: 0000001
2020-04-24 11:36 guttmann Resolution open => fixed
2020-08-17 09:49 guttmann Fixed in Version 1.1 => 1.0
2020-09-30 14:45 guttmann Project @6@ => jFermi