View Issue Details

IDProjectCategoryView StatusLast Update
0000017jFermiGeneralpublic2020-09-30 14:45
Reporterguttmann Assigned Toguttmann  
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Target Version5.8Fixed in Version5.8 
Summary0000017: pump control modules throws I/O errors sometimes:
Descriptionpump control module throws these exceptions sometimes:

Aug 21 14:24:13 raspberrypi jdesktop[422]: /usr/share/javascript/jdesktop/i2c/i2c.js: Uncaught Error: Remote I/O error at line 32
Aug 21 14:24:13 raspberrypi jdesktop[422]: /var/www/html/jpumptest/server.jss: parallax.js: writeBlockData failed: Error: Remote I/O error
Aug 21 14:24:13 raspberrypi jdesktop[422]: /usr/share/javascript/jdesktop/i2c/i2c.js: Uncaught Error: Remote I/O error at line 32
Aug 21 14:24:13 raspberrypi jdesktop[422]: /usr/share/javascript/jdesktop/i2c/i2c.js: Uncaught Error: Remote I/O error at line 32
TagsNo tags attached.

Activities

guttmann

2020-08-22 15:07

administrator   ~0000006

it seems that the pump control module is too busy to handle i2c communication (interrupt based solution, it starvation)
current implentation uses 4 other pin interrupts and I think it fires too often and sometimes this causes to problem
firmware should be modified but because in the future we will use serial communiation for now we decreased the i2c bus speed to 10kHz

/boot/config.txt
dtparam=i2c_arm=on,i2c_arm_baudrate=10000

Issue History

Date Modified Username Field Change
2020-08-21 14:24 guttmann New Issue
2020-08-21 14:24 guttmann Status new => assigned
2020-08-21 14:24 guttmann Assigned To => guttmann
2020-08-22 15:07 guttmann Status assigned => resolved
2020-08-22 15:07 guttmann Resolution open => fixed
2020-08-22 15:07 guttmann Fixed in Version => 5.8
2020-08-22 15:07 guttmann Note Added: 0000006
2020-09-30 14:45 guttmann Project @7@ => jFermi